Jump to content

Horus X10 Express


Brian Dorricott 1
 Share

Recommended Posts

I got one of the above delivered today and after playing with it for a while decided I would like to backup the Ethos operating system before maybe putting on OTX later . I took the supplied USB cable plugged into the Win10 PC and found straight away that it didn't find a driver for the device but did appear as an X10 joystick . Odd I tried another PC and again it appeared as a X10 joystick but not a port so someone suggested try it in bootloader mode which I did and this time I could see the SD card contents but not the internal flash contents . 

Am I missing something obvious ?

Lots of you tube vids show the USB lead being plugged in and the internal flash and SD card contents being visible but not on this one . I have even tried a WIN7 PC but no change and tried several different USB leads but again no change .

With it showing joystick not USB  I looked for a switch in Ethos like the one in OTX where the option is "ask" but there is nothing that I can find . 

Anyone shed any light on it for me , I am thinking of sending it back at the moment as I can't get anywhere with it .

All replies gratefully received even if I'm an idiot and missed the obvious. 

Link to comment
Share on other sites

3 minutes ago, Ron Gray said:

I know that the recent upgrade to incorporate LUA scripts was a big leap forward Kevin but are there any other parts of OTX that haven't yet been replicate in ETHOS that are 'significant' ?

Ron, you must have replied before I edited my post where I said that I would not go back to OpenTX?.

 

So far I have not found anything other than "instant trim" which has been raised as an issue that I could do in OTX that ETHOS lacks.

I can lend you an X12S with ETHOS on if you want to have a play.

 

Link to comment
Share on other sites

Thanks Kevin but I've already 'upped' my X12S to ETHOS but need to get the latest version then actually try it out (I changed to ETHOS but have never used it in anger!!!). I have been contemplating upping my X10S to ETHOS but was holding back as I have a lot of LUA scripts on it, mainly for when I use iNav. Maybe I should just try the X12S first and see if everything is OK on that.....................????

Link to comment
Share on other sites

Sorry Kevin if there's no internal flash where is the radio upgraded because the X10 works without an SD card . Every you tube update video shows a flash plus sd card contents . Are there any forums where I could ask my question ? I was looking for someone on here with a X10 Express running Ethos to plug in a USB cable and confirm what happens regards what appears . I know the procedure with X7 and the RM Tx16 for upgrading but this without seeing firmware is a bit of a pain .

Link to comment
Share on other sites

From this list

Write protected? Right Click to check card properties as the card may be locked.

Disk Management to decide How cards are displayed.

Enable Card Reader.

 

I doubt you have an Horus Tx problem.

Just card handling not set.

  • How can I fix my micro SD card not detected 
  • To fix SD card not detected or SD card not showing up issue, use the following tips:
    • Try SD card on another device.
    • Check SD card in Disk Management.
    • Remove SD card write protection.
    • Reinstall/update SD card driver.
    • Enable SD card reader.
    • Run hardware and device troubleshooter.
    • Repair corrupted SD card.
Edited by Denis Watkins
Link to comment
Share on other sites

Sorry not making myself clear , I can read the SD card either via a card reader or by going into bootloader that is not a problem , reading or seeing the internal flash is the problem . After much googling and a read on github I managed to update the Ethos version from 1.0.9 to 1.0.19 by placing the firmware.bin in the sdcard root and running bootloader , read it and flashed it to radio - success . Now how do I get OpenTX on it using that method because the OTX bootloader will be wrong I think .

Any ideas anyone ? 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...